Topic: Can't read MAX66040

I have SCL3711 reader and libnfc installed.

I use command:
nfc-poll -v | grep -v '^trace'

It shows me information for Mifare DesFire, Mifare Classic, NXP JCOP, but not for MAX66040. My reader doesn't see this cards (I tried 3 different MAX66040 cards). What can be the reason of this?

Re: Can't read MAX66040

I read them, but at the extremly low range. It can be read only if the chip area is close right up to the reader. But nfc-anticol still doesn't see this card:

NFC reader: SCM Micro / SCL3711-NFC&RW - PN533 v2.7 (0x07) opened

Sent bits:     26 (7 bits)
Error: No tag available

Does anybody have the same problem with MAX66040?

3 (edited by tyson.key 2012-04-09 20:07:03)

Re: Can't read MAX66040

As far as I know, nfc-anticol only supports ISO/IEC 14443-A cards - which is why you don't see the MAX66040 (or FeliCa cards) in its output.

You can however enumerate them using nfc-list, and nfc-poll; and I posted a TAMA shell script in my thread regarding these cards that allows you to test the Get System Information command.