Topic: [Solved] Mifare Desfire : Send Deselect command

I obtain 0x 67 00 status word  when I send Deselect command to a Mifare Desfire Card, which means 'transport layer error'. I don't know why I have this error since I send this command while the card is in the active state. I sent many commands without problem ( authenticate, read, write, etc), but when I want to halt the card, it doesn't work. I can't either send a Halt command because as I already said, the card is in active state, so, to become in halt state, I can only send the Deselect command : 0xC1.

Thanks in advance for your help

Re: [Solved] Mifare Desfire : Send Deselect command

Please refers to DESFire documentation.

Romuald Conty

3 (edited by rokia.lamrani.alaoui 2015-04-27 09:28:36)

Re: [Solved] Mifare Desfire : Send Deselect command

Thank you for your answer. In fact, I found why I can't send the Deselect command, My card was in a state (TgGetData)  where it can accept only I-blocks while the deselect command is an S-block. So, I think the chip of the reader is only capable to send Deselect command to the chip of the card if an error occurs, but it is not possible to send it from the application level as I want to do.