1 (edited by ongjohn 2013-12-15 14:26:47)

Topic: [SOLVED] ACR122U__ Unable to write to USB


I met a problem that puzzled me for a long time. I hope somebody can help me.

device: acr122
p/n: acr122u-a1noct1

env:vmware 9.0

linux: fedora 17

libnfc-1.7.0  -------------- install ok.
ccid-1.4.14  -------------- install ok.
pcsc-lite-1.8.10 --------- install ok.

[root@localhost lazy]# nfc-list
nfc-list uses libnfc 1.7.0
No NFC device found.

[root@localhost lazy]# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse
Bus 002 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub
Bus 002 Device 007: ID 0e0f:0008 VMware, Inc. 
Bus 002 Device 010: ID 0e0f:0004 VMware, Inc. Virtual CCID

----------------------------- above problem has solved ---------------------------------------------------
but it comes a new problem as blow!!

[root@localhost lazy]# pcscd -d -f
00000000 pcscdaemon.c:240:main() pcscd set to foreground with debug send to stdout
00001868 configfile.l:307:DBGetReaderList() Parsing conf file: /usr/local/etc/reader.conf.d
00000351 pcscdaemon.c:545:main() pcsc-lite 1.8.10 daemon ready.
00008160 hotplug_libusb.c:515:HPAddHotPluggable() Adding USB device: 2:9:0
00000428 readerfactory.c:989:RFInitializeReader() Attempting startup of ACS ACR122U PICC Interface 00 00 using /usr/local/lib/pcsc/drivers/ifd-ccid.bundle/Contents/Linux/libccid.so
00000598 readerfactory.c:874:RFBindFunctions() Loading IFD Handler 3.0
00000364 ifdhandler.c:1851:init_driver() Driver version: 1.4.14
00001495 ifdhandler.c:1868:init_driver() LogLevel: 0x0003
00000286 ifdhandler.c:1879:init_driver() DriverOptions: 0x0004
00000488 ifdhandler.c:83:CreateChannelByNameOrChannel() Lun: 0, device: usb:072f/2200:libusb-1.0:2:9:0
00000347 ccid_usb.c:281:OpenUSBByName() Using: /usr/lib/pcsc/drivers/ifd-ccid.bundle/Contents/Info.plist
00001186 ccid_usb.c:299:OpenUSBByName() ifdManufacturerString: Ludovic Rousseau (ludovic.rousseau@free.fr)
00000311 ccid_usb.c:300:OpenUSBByName() ifdProductString: Generic CCID driver
00000293 ccid_usb.c:301:OpenUSBByName() Copyright: This driver is protected by terms of the GNU Lesser General Public License version 2.1, or (at your option) any later version.
00059403 ccid_usb.c:589:OpenUSBByName() Found Vendor/Product: 072F/2200 (ACS ACR122U PICC Interface)
00000039 ccid_usb.c:591:OpenUSBByName() Using USB bus/device: 2/9
00000027 ccid_usb.c:1047:ccid_check_firmware() Firmware (1.03) is bogus! but you choosed to use it
00004230 ccid_usb.c:1086:get_data_rates() IFD does not support GET_DATA_RATES request: 0
05351772 ccid_usb.c:745:WriteUSB() write failed (2/9): -7 Success
05001659 ccid_usb.c:745:WriteUSB() write failed (2/9): -7 Success
05002329 ccid_usb.c:745:WriteUSB() write failed (2/9): -7 Success
00000051 ifdhandler.c:158:CreateChannelByNameOrChannel() failed
00000025 readerfactory.c:1020:RFInitializeReader() Open Port 0x200000 Failed (usb:072f/2200:libusb-1.0:2:9:0)
00000016 readerfactory.c:312:RFAddReader() ACS ACR122U PICC Interface init failed.
00000020 readerfactory.c:535:RFRemoveReader() UnrefReader() count was: 1
00000016 readerfactory.c:1040:RFUnInitializeReader() Attempting shutdown of ACS ACR122U PICC Interface 00 00.
00000014 readerfactory.c:911:RFUnloadReader() Unloading reader driver.
00000299 hotplug_libusb.c:422:HPEstablishUSBNotifications() Driver ifd-ccid.bundle does not support IFD_GENERATE_HOTPLUG. Using active polling instead.
00000022 hotplug_libusb.c:431:HPEstablishUSBNotifications() Polling forced every 1 second(s)

[root@localhost lazy]# nfc-scan-device -v -i
nfc-scan-device uses libnfc 1.7.0
1 NFC device(s) found:
error    libnfc.driver.acr122_usb    Unable to write to USB (Connection timed out)
nfc_open failed for acr122_usb:002

Can Anybody Help me!!!!!

Re: [SOLVED] ACR122U__ Unable to write to USB

OK, I  have solved the problem.....

Re: [SOLVED] ACR122U__ Unable to write to USB

For the record, I think it was due to :
- USB forward to virtual machine
- Choose acr122_usb as built in default configuration without any PCSC driver, or compile and use acr122_pcsc driver (libnfc) with PCSC driver (proprietary) (not recommended).

Romuald Conty

Re: [SOLVED] ACR122U__ Unable to write to USB

ongjohn wrote:

OK, I  have solved the problem.....

So, tell me pease the solution