Topic: Disable automatic get response

Is it possible to disable automatic get response command using T=CL and libnfc? Each time I send a command I'm not able to get only 61XX but instead I get the complete response from my card.

When sending the same command on it in contact mode I get only the 61 XX. But in contactless with libnfc I get the response completely.

Thanks

Now:
00 A4 02 00 02 XX XX
YY ZZ AA DD DD DD FF DD SS 90 00

Desired:
00 A4 02 00 02 XX XX
61 ZZ

Re: Disable automatic get response

Wow!!

Nice Information

3 (edited by jlanza 2012-11-23 08:39:20)

Re: Disable automatic get response

Ironic? wink

Re: Disable automatic get response

I think it's a spam bot, look at its nickname (San Diego dentists)
Probably a broken spam bot ;-)

To answer your question, you get a 61xx by contact because you're using T=0 (cf ISO7816-3 chapter 12.2 for details)
In contactless T=CL the mapping is basically the same as for T=1which does not use 61xx (cf ISO14443-4 for details)

Phil

Re: Disable automatic get response

Thanks.. I will have a look at it and reconfigure my program. Let's see if it works.

See you